Active forum topics

©2006-2017 IAAI Software

Contact Us Privacy Policy

Links stop working with static page enabled

Submitted by bodybuildingcom... on Tue, 2017-08-15 20:38.

Hi David,

When I set my WordPress to have a static homepage and a posts page, the links i.e. category, brand, merchant, as well as the search box stops working.

I am wondering if you have an idea on why that is? Would it be because it is a virtual href issue? It would be great if I could have a separate static page from the blog posts (Shopping page).

Thanks.

Norbert

Submitted by support on Wed, 2017-08-16 09:10.

Hello Norbert,

I was able to re-create this by creating a new page "Homepage", enabling Static pages and then selecting "Homepage" as Front page, and "Shopping" as Posts page.

What this does is override the Shopping page from being displayed, and instead shows the Blog (posts from newest to oldest by default). It was no problem if I created a second new page "Blog", and set this as the Posts page. There was then no interference with /shopping and the A-Z links / search work fine.

However, if you don't intend to use posts at all, and didn't want to have separate pages and end up with a blank page "Posts", then simply create a single post containing the shortcode [pto] and assign your Shopping page as the Posts page and that should do the trick...

Hope this helps!

Cheers,
David.
--
PriceTapestry.com

Submitted by bodybuildingcom... on Thu, 2017-08-17 18:58.

Hi David,

Thank you for testing it for me. Yes, it seems, if you create a new static page for the homepage and a new blog page, the links will not be affected. But, if you only create one or the other, and set static pages, the links, search etc. will not work.

Just thought I mention it, in case someone else may experience something similar.

Thanks.

Norbert